Users unable to log into app

Tried logging into the app today via touch id on ios and nothing happens.

Took me to the passcode screen afterwards and nothing happens there either?

Tried turning phone on and off and also deleting the app and re-downloading. Anyone else experiencing similar issue?

1 Like

I’ve raised this with the technical team. I will look into this for you

1 Like

Keeps loading in this screen after deleting and downloading again

Can I check whether this is on iOS or Android?

I am having the same issue. Everytime I enter my passcode into the app it says:
Ooops! Something went Wrong! Please try again later
This is via Android

1 Like

Also experiencing this on Android

For me iOS

Update: its working for me

1 Like

The issue has been identified by the team and a fix is being implemented.

As soon as I have a better indication of when everyone will be able to access the app, I will let you know.

The issues yesterday evening have now been fixed.

Android users: please update to version 1.6.2

Please leave us a comment below if you have any ongoing issues, or contact Customer Service at

These were a result of updates to some security settings. We are looking into why these changes affected customers as they did, and we will be able to give you more details later today after our investigation.

If you are using iOS / Apple: There was a brief period when you were unable to log in, but this was resolved in the afternoon and you should have been able to log in again. Please let us know if this is still affecting you.

If you are using Android: ALL customers on Android need to update to the very latest version (1.6.2). It includes a security update so without it you will not be able to log in.

In the case of Android, the fix required some changes to the app itself, so whatever version you currently have installed, and whatever your specific device, you will need to make sure you go to the Google Play store to download the update

I still can’t log in, I get ‘oops something went wrong’ error and have been doing so since yesterday. Just checked and I am using version 1.6.1 however no updates are available for the app in the Google Play store.

What should I do?

The latest update is in the app store. You may need to open the Play app and search for the Dozens app rather than rely on the automatic update process.

Please let me know if that works

This worked for me. But as I imagine most people who use Dozens won’t use the forum, it would be good to have a push notification or change the error message to say please update.
Edit: I did check for an update but may not be obvious to all.

1 Like

Yes, there will be various updates going out this morning. This is just the first of them to those who had already reported the issue

Glad to hear you were able to update your app

1 Like

I had searched in the play store (for the reasons you suggested) several times between last night and just before I posted this morning and it was only offering up 1.6.1. However I’ve just done it again now and it’s offering 1.6.2. is the update being staggered?

I’ve just updated and can get in now thanks!

1 Like

This is not staggered by us, but I’m not sure about how Google itself rolls out these updates once they are submitted by the developers. It is probably about refreshing the Play app in some way to get the latest information from their servers.

Glad to hear you found it. Hopefully it will be available to all customers by now

I had the same issue last night. So waited until this morning to see if it was resolved. Noticed the android app needed updated. So my previous version wouldnt update, so I un-installed it, then did fresh install. Once installed, I entered my other mobile number by mistake, so then entered the correct mobile number. But now everytime I try logging in, my account says its “Currently Unavailable”.

I have been on your chat pages to discuss this and sent them screenshots of the app page and the Google Play app page.

So are still waiting to hear back as still cant log into my online account or even use my Dozens card

Unable to login :thinking:

Yes, the system seems to be haywire at the moment. I’ve also had a transaction that wasn’t from me so I’ve flagged and been frantically trying to freeze my card for 10 minutes but getting the error message you have. Finally managed it. Obviously a major systems issue!

If you dismiss that notification, does it then work? It appears to be OK otherwise

We are looking into this in any case, thanks for the notification