Unable to add money to buy a bond using the purchase bond flow

So when I go to add a bond and I don’t have enough money you can’t add money using the apps flow.

Android 9 latest version of the app

Aa can be seen in the video it only enters 0 no other numbers

Thanks for the video - that’s very useful

I will forward this to the technical team straight away.

It is very odd behaviour

Can you let me know (by PM if you prefer) your device, (thanks for the OS and version of the app) you are using? Thanks

As a matter of interest, have you tried transferring money to cash savings BEFORE going through the bond bidding process, rather than when prompted?

If you click on the Grow tab, you can then click on the :heavy_plus_sign: next to your current balance to boost your savings.

Do you get the same error here?

Hi. I wanted to make a bid but app is not working properly. I had to put in cash to saving account but when I type any figure nothing appears. It is always zero. I wrote six emails and messages to technical support. But their support is awful and unprofessional. They advised nothing or didn’t reply at all.
I think I will be miles away from your bonds and others products because I like to sleep well. And I am very disappointed that I invested in your business.

I’m sorry you are having an issue. I see that others have reported this too, so we are looking into it. The customer service team are not the developers so we have no idea when this will be resolved.

As an aside, as you can imagine, we get lots of tickets at times like these on all sorts of matters (new accounts, transfers, etc.), so sending 6 separate messages will only complicate our ability to follow up and make sure that we have logged your report and got back to you. Please give the team a chance to follow up.

I will look into this and see if we can get this resolved quickly.

1 Like

The + isn’t clickable in the grow section, so no that doesn’t work.

Huawei P20 Pro

Android 9.1

App version 1.6.5 (Build 579)

1 Like

Thanks for that. It was worth a try.

Can I assume that there is money in your main/primary current account and the account has not been frozen by you in the app for any reason? Just a passing thought (I am not able to check at the moment)

There is no money in the account at all (well £2 that we was given), I was waiting for the bonds and direct debits or standing orders, so there was no reason to put money in it. I’ve literally only reinstalled the app when you announced bonds are back, so until the other day the app wasn’t even on my phone.

Right. OK. This could be at least part of the issue.

You can only move money into Cash Savings from your current account. You cannot pay into it directly.

SO you will therefore first have to transfer funds into your primary account either through a top-up or a bank transfer. Once they are in the account, you can then put money into cash savings and be able to bid on the bonds.

This may not be the sole issue, but certainly it will not be possible to bid on bonds without having done this first.

Hope that helps

Well that definitely needs changing or explaining, because it clearly says Top up your cash savings in the flow. And also it makes it complicated if you have to do lots of steps.

Meaningful (error) messages for things like this would be great. So, you try to add to Savings and it tells you that you need money in your account first.

1 Like

Yeah knowing you can’t do something helps, but the flow is obviously wrong, it should tell you to add money, before you select start to create a bond. Although a decent error message would have meant no need to post here about it.

1 Like

I still can’t do this. Unable to add anything other than 0’s. Unable to press the + button to savings.

There is money in my current account. Just unable to move it to savings. Very frustrating.

As you’ve not posted in a while…

Have you got the latest app version, have you moved and funds that may have been associated with you old MasterCard to your new account? (The balance I assume needs to show on your visa, not MasterCards in the spend screen)

Just checked and all working well on my Mate 20 Pro. I can see how some of the workflow can be confusing at first but after a little while I find it far more intuitive than Revolut for example.

I have the latest app version on iPhone. I have auto updates turned on in any case.

I had to delete and reinstall the app twice. Finally. The plus button was no longer grayed out and I could transfer to savings.

This needs to get better.

I’m looking forward to the next version of the app, which will hopefully sort out some of the long-standing issues, including balances updating promptly when you transfer between Spend and Grow, ISA
/GIA separation, Grow not including pending bond funds etc…